gamepick-0.35-r2.ebuild

Download (647 Bytes)

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools desktop

DESCRIPTION="Launch opengl games with custom graphic settings"
HOMEPAGE="http://www.rillion.net/gamepick/index.html"
SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_prepare() {
	default

	sed -i \
		-e 's/-O2//' \
		src/Makefile.in || die

	# Clang 16, bug #898998
	eautoreconf
}

src_install() {
	default
	newicon ${PN}-48x48.xpm ${PN}.xpm
	make_desktop_entry ${PN} ${PN}
}

Thank you!