Tk-TableMatrix-1.290.0.ebuild

Download (684 Bytes)

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DIST_AUTHOR=CAC
DIST_VERSION=1.29
inherit perl-module virtualx

DESCRIPTION="Create and manipulate tables in Perl + Tk"

LICENSE="Artistic"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ~riscv sparc x86 ~amd64-linux ~x86-linux"

RDEPEND="
	>=dev-perl/Tk-800.22.0
"
BDEPEND="${RDEPEND}
	>=virtual/perl-ExtUtils-MakeMaker-6.520.0
"

src_test() {
	virtx perl-module_src_test
}

src_install() {
	perl-module_src_install

	# Clean out stray conflicting file - it's generated by perl-tk already.
	# Bug #169294
	rm "${D}"/${VENDOR_ARCH}/auto/Tk/pTk/extralibs.ld || die
}

Thank you!