[SOLVED] Calculate Update keeps removing and reinstalling a package plus maybe dependencies and others

Added by Jose Jurado 22 days ago

Calculate Linux is a great distro, but in this x86_64 installation the Calculate Linux Update facility keeps removing and reinstalling the same files at nearly every daily update. Some of the files, I am under the impression, may be dependencies to app-text/xiphos-4.0.6a, a Bible study package.

Note 1: Xiphos required some flags to be set on another recent Calculate Linux installation when xiphos was being installed with many other packages; however, in the current installation for some reason only two other packages reported needing flags to be set - clamtk and thermald - (not xiphos) for which autounmask-write and dispatch-conf were applied with root privileges.

Note 2: The system was installed a few days ago using the 'overnight' updated iso file cldxe-20180817-x86_64.iso. (The jwm window manager was very easily installed and it is the environment being used).

Today, the Calculate Linux Update facility only offered what seems to be the removal and rebuild of the same packages, as often happens:

Sep 3 2018:

"Listing packages for removal
  • Tools to convert docbook to man and info app-text/docbook2X-0.8.8-r4
  • A collection of documentation utilities for the Gnome project app-text/gnome-doc-utils-0.20.10-r1
  • A documentation metadata library app-text/rarian-0.8.1-r3
  • Perl binding for libxml2 dev-perl/XML-LibXML-2.13.200
  • A Perl module that offers a simple to process namespaced XML names dev-perl/XML-NamespaceSupport-1.120.0
  • Perl module for using and building Perl SAX2 XML parsers, filters, and drivers dev-perl/XML-SAX-1.0.0
  • Base class SAX Drivers and Filters dev-perl/XML-SAX-Base-1.90.0
  • Internationalization Tool Collection dev-util/intltool-0.51.0-r2
  • A multicast protocol to support Bible software shared co-navigation net-libs/biblesync-1.1.2-r2"

After responding 'Yes' to whether to unmerge those packages, the process continues with:

"Rebuilding dependent modules
(1 of 10) A multicast protocol to support Bible software shared co-navigation
Emerging net-libs/biblesync-1.1.2-r2
(2 of 10) A Perl module that offers a simple to process namespaced XML names
Emerging dev-perl/XML-NamespaceSupport-1.120.0
(3 of 10) Base class SAX Drivers and Filters
Emerging dev-perl/XML-SAX-Base-1.90.0
(4 of 10) A collection of documentation utilities for the Gnome project
Emerging app-text/gnome-doc-utils 0.20.10-r1
Installing net-libs/biblesync 1.1.2-r
(5 of 10) A documentation metadata library
Emerging app-text/rarian 0.8.1-r
Installing dev-perl/XML-NamespaceSupport-1.120.0
(6 of 10) Internationalization Tool Collection
Emerging dev-util/intltool 0.51.0-r
Installing dev-perl/XML-SAX-Base-1.90.0
Installing app-text/gnome-doc-utils 0.20.10-r1
Installing app-text/rarian 0.8.1-r
Installing dev-util/intltool 0.51.0-r
(7 of 10) Perl module for using and building Perl SAX2 XML parsers, filters, and drivers
Emerging dev-perl/XML-SAX 1.0.0
Installing dev-perl/XML-SAX 1.0.0
(8 of 10) Perl binding for libxml2
Emerging dev-perl/XML-LibXML 2.13.200
Installing dev-perl/XML-LibXML 2.13.200
(9 of 10) Tools to convert docbook to man and info
Emerging app-text/docbook2X 0.8.8-r4
Installing app-text/docbook2X 0.8.8-r4
(10 of 10) A bible study frontend for Sword (formerly known as GnomeSword)
Emerging app-text/xiphos-4.0.6a
Installing app-text/xiphos-4.0.6a
Updating configuration files
System update finished!"

Note 3: In case this could be relevant, package searches indicate that there are TWO versions available for FOUR of those packages:

[I] net-libs/biblesync
     Available versions:  1.1.2-r2{tbz2} ~2.0.1 {static}
     Installed versions:  1.1.2-r2{tbz2}(05:11:57 PM 08/28/2018)(-static)
     Homepage:            http://www.crosswire.org/wiki/BibleSync
     Description:         A multicast protocol to support Bible software shared co-navigation

[I] dev-perl/XML-SAX
     Available versions:  0.990.0-r1 1.0.0{tbz2}
     Installed versions:  1.0.0{tbz2}(11:36:02 AM 08/28/2018)
     Homepage:            http://search.cpan.org/dist/XML-SAX/
     Description:         Perl module for using and building Perl SAX2 XML parsers, filters, and drivers

[I] dev-perl/XML-LibXML
     Available versions:  2.12.800-r1 ~2.12.900 2.13.200{tbz2} {examples minimal test}
     Installed versions:  2.13.200{tbz2}(11:44:45 AM 08/28/2018)(-examples -minimal -test)
     Homepage:            http://search.cpan.org/dist/XML-LibXML/
     Description:         Perl binding for libxml2

[I] app-text/xiphos
     Available versions:  4.0.6a-r1 ~4.1.0-r1 {dbus debug PYTHON_TARGETS="python2_7"}
     Installed versions:  4.0.6a-r1(01:15:20 PM 09/03/2018)(dbus -debug PYTHON_TARGETS="python2_7")
     Homepage:            http://xiphos.org/
     Description:         A bible study frontend for Sword (formerly known as GnomeSword)

Note 4: Perhaps the output for the following may be helpful when trying to find conflicts, as inspired by another Calculate Linux forum post:

$ emerge -avquDN --with-bdeps=y @world --verbose-conflicts

The output is posted here.

Note 5: This recurring problem had occurred with my previous Calculate Linux installation, which had been regularly updated. In that installation, I don't think xiphos required any flags to be set either (unlike an even earlier installation of Calculate Linux). From my notes:

Aug 19 2018:

"Listing packages for removal
  • Tools to convert docbook to man and info app-text/docbook2X-0.8.8-r4
  • A collection of documentation utilities for the Gnome project app-text/gnome-doc-utils-0.20.10-r1
  • A documentation metadata library app-text/rarian-0.8.1-r3
  • Perl binding for libxml2 dev-perl/XML-LibXML-2.13.200
  • A Perl module that offers a simple to process namespaced XML names dev-perl/XML-NamespaceSupport-1.120.0
  • Perl module for using and building Perl SAX2 XML parsers, filters, and drivers dev-perl/XML-SAX-0.990.0-r1
  • Base class SAX Drivers and Filters dev-perl/XML-SAX-Base-1.90.0
  • Internationalization Tool Collection dev-util/intltool-0.51.0-r2"
    [...]

Then:

"Rebuilding dependent modules
Updating preserved libraries
(1 of 10) A multicast protocol to support Bible software shared co-navigation
Emerging net-libs/biblesync-1.1.2-r2
(2 of 10) A Perl module that offers a simple to process namespaced XML names
Emerging dev-perl/XML-NamespaceSupport-1.120.0
(3 of 10) Base class SAX Drivers and Filters
Emerging dev-perl/XML-SAX-Base-1.90.0
[etc, up to...]
(10 of 10) A bible study frontend for Sword (formerly known as GnomeSword)
Emerging app-text/xiphos-4.0.6a
Installing app-text/xiphos-4.0.6a
Updating configuration files
System update finished!"

When xiphos was removed in that earlier installation, the problem resolved. The leftover dependencies, presumably, or unneeded packages were offered to be removed also - including ?some of the above, if I remember correctly. However, I would like to preserve Xiphos this time. Could anyone suggest some repair attempts please? Thank you!


Replies (2)

RE: Calculate Update keeps removing and reinstalling a package plus maybe dependencies and others - Added by Jose Jurado 19 days ago

Update No.1: Today, the Calculate Linux Update facility announced an error even though I didn't change any package management setting:

6 Sept 2018:
"[...]
Removing obsolete distfiles and binary packages..................................FAILED
ActionError:Wrong method for task cleanpkg(calculate.core.server.func:449)
Synchronization finished
System configuration
Update server was changed to http://miroir.linuxtricks.fr/calculate
[...]
Listing packages for installation
  • Gentoo's multi-purpose configuration and management tool (U) app-admin/eselect-1.4.13 (86 KiB) [not listed in ]
  • Full-strength general purpose cryptography library (including SSL and TLS) (U) dev-libs/openssl-1.0.2o-r6 (4378 KiB)
  • Inject some useful and sensible default behaviors into setuptools (U) dev-python/pbr-4.2.0-r1 (298 KiB)
  • Download videos from YouTube.com (and more sites...) (U) net-misc/youtube-dl-2018.08.22 (7714 KiB)
  • A set of Calculate utilities for system installation, build and upgrade (U) sys-apps/calculate-utils-3.6.0.2 (2628 KiB)
  • Linux Key Management Utilities (U) sys-apps/keyutils-1.5.10-r1 (108 KiB)
  • Standard tool to compile source trees (U) sys-devel/make-4.2.1-r4 (542 KiB)
  • Utility to apply diffs to files (U) sys-devel/patch-2.7.6-r2 (153 KiB)
  • Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump) (U) sys-libs/timezone-data-2018e (310 KiB)

Update 2:
The other surprise that developed today therefore is that the update listing for today suggested two packages for installation whose versions (listed above) are different than those listed on the website today as new packages for today or for the previous two days (I may not have updated the system for two days):
dev-libs/openssl-1.0.2o-r6 is not the version listed as "new" today at that webpage; the new versions are openssl-1.0.2p
and openssl-1.1.1_pre9
- net-misc/youtube-dl-2018.08.22 is not the version listed as "new" today at that webpage; the new version is youtube-dl-2018.09.01

Note also that the other 7 packages are not listed on that webpage as new packages for today or for the previous two days.

Then, as typical, the same 8 packages as on 19 Aug 2018 (see above) were listed for removal by the update facility, plus net-libs/biblesync-1.1.2-r2 (also listed for removal on other occasions). All those packages were subsequently rebuilt by the facility, and xiphos-4.0.6a-r1 was emerged and installed. This is the difficulty that I was concerned about originally.

RE: Calculate Update keeps removing and reinstalling a package plus maybe dependencies and others - Added by Jose Jurado 1 day ago

Update 3:
The problem seemed to be solved a few days later, if I remember correctly, possibly by running the following (not as root nor as sudo) in a terminal:

cl-update

(1-2/2)

Thank you!