(Newbie question) Issues installing x11-misc/redshift-1.10

Added by Shazia Juna over 2 years ago

I have installed Calculate Linux Mate Desktop on my laptop today, so I am a newbie. I followed the documentation on the Calculate Linux website and I updated the system without any issues. Also managed to install wacom drivers and some other software, no problems at all, it was pretty straightforward.

I am trying to install redshift (x11-misc/redshift-1.10). I need some advice here, on how to resolve this issue with python configuration. I get the following error when trying to install via emerge (see below). Thanks for any tips and your time in advance!!

No Python implementation selected for the build. Please add one
  • of the following values to your PYTHON_TARGETS (in make.conf):

  • python3_3 python3_4

  • ERROR: x11-misc/redshift-1.10::gentoo failed (configure phase):
  • No supported Python implementation in PYTHON_TARGETS.

  • Call stack:
  • ebuild.sh, line 93: Called src_configure
  • environment, line 4165: Called python_export_best
  • environment, line 3574: Called _python_obtain_impls
  • environment, line 660: Called _python_validate_useflags
  • environment, line 715: Called die
  • The specific snippet of code:
  • die "No supported Python implementation in PYTHON_TARGETS."

Replies (2)

RE: (Newbie question) Issues installing x11-misc/redshift-1.10 - Added by Alexander Tratsevskiy over 2 years ago

Hi Shazia,
Try add the flag PYTHON_TARGETS="python3_4" to x11-misc/redshift:

echo "x11-misc/redshift python_targets_python3_4" >> /etc/portage/package.use/custom

RE: (SOLVED-Newbie question) Issues installing x11-misc/redshift-1.10 - Added by Shazia Juna over 2 years ago

Hello Alexander,

A big THANKS for your suggestion and it worked!! I am really pleased with the setup and learning my way around Calculate Linux and Portage.

Once again thanks and wishing you all the best!!

(1-2/2)

Thank you!