Gyachi install

Added by valerian_ se almost 5 years ago

I installed cldg-13.4-x86_64. I am very pleased how it works.
But there are beginner and do not know how to install programs from external sources.
I tried Gyachi.And this is the result:

!!! Problem resolving dependencies for net-im/gyachi ... done!
!!! The ebuild selected to satisfy "net-im/gyachi" has unmet requirements.
- net-im/gyachi-1.2.11-r1::x-portage USE="alsa libnotify (multilib) -blowfish -gpgme -gtkhtml -gtkspell -mcrypt -pulseaudio -voice -webkit" ABI_X86="64" CDISTRO="CLDG desktop" 
The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( gtkhtml webkit )

Can anyone help me here?

Replies (3)

RE: Gyachi install - Added by Iurii Blokhin almost 5 years ago

The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( gtkhtml webkit )

This means that you must add line to /etc/portage/package.use/custom

net-im/gyachi alsa libnotify multilib webkit

or

net-im/gyachi alsa libnotify multilib gtkhtml

RE: Gyachi install - Added by valerian_ se almost 5 years ago

Mr. Yuriy Blokhin thank you very much for your answer!
I really want to learn it got Calculate Linux
To learn how to install a program I was inspired here

http://www.youtube.com/watch?v=HyL-_ZQGPVc

After I added this line
net-im/gyachi alsa libnotify multilib gtkhtml

I saw this
lisistrata gyachi # emerge -av net-im/gyachi
WARNING: One or more repositories have missing repo_name entries:

    /usr/local/portage/profiles/repo_name
NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.
These are the packages that would be merged, in order:
Calculating dependencies... done!
emerge: there are no ebuilds to satisfy "gnome-extra/gtkhtml:2".
(dependency required by "net-im/gyachi-1.2.11-r1::x-portage[gtkhtml]" [ebuild])
(dependency required by "net-im/gyachi" [argument])


And because they are very beginner.And now I know what to do.
Please if you have time to explain how to install Gyachi in small steps.
Or give me a link where I can find information.
Thanks in advance!

RE: Gyachi install - Added by Iurii Blokhin almost 5 years ago

replace gtkhtml to webkit

(1-3/3)

Thank you!