cl-update fails with python 2.7 errors

Added by Robert Stockdale 4 months ago

Having trouble updating my laptop running CDLM. The error message I get is:

calculate / # cl-update
Traceback (most recent call last):
File "/usr/lib64/python2.7/site-packages/calculate/core/server/func.py", line 636, in run
run_context = self.get_condition_context(action, result)
File "/usr/lib64/python2.7/site-packages/calculate/core/server/func.py", line 589, in get_condition_context
[self.runCondition(x) for x in condition_funcs])
File "/usr/lib64/python2.7/site-packages/calculate/core/server/func.py", line 529, in runCondition
return func_condition(*args)
File "/usr/lib64/python2.7/site-packages/calculate/update/utils/cl_update.py", line 206, in <lambda>
not Get('cl_update_binhost_data')[0])
File "/usr/lib64/python2.7/site-packages/calculate/lib/datavars.py", line 1434, in Get
var = self.Get(varname, humanreadable)
File "/usr/lib64/python2.7/site-packages/calculate/lib/datavars.py", line 1494, in _Get
res = varObj._get()
File "/usr/lib64/python2.7/site-packages/calculate/lib/datavars.py", line 412, in _get
value = self.get()
File "/usr/lib64/python2.7/site-packages/calculate/update/variables/update.py", line 306, in get
last_ts = self.Get('cl_update_last_timestamp')
File "/usr/lib64/python2.7/site-packages/calculate/lib/datavars.py", line 286, in Get
res = self.parent.Get(varname, humanreadable)
File "/usr/lib64/python2.7/site-packages/calculate/lib/datavars.py", line 1434, in Get
var = self.
_Get(varname, humanreadable)
File "/usr/lib64/python2.7/site-packages/calculate/lib/datavars.py", line 1494, in __Get
res = varObj._get()
File "/usr/lib64/python2.7/site-packages/calculate/lib/datavars.py", line 412, in _get
value = self.get()
File "/usr/lib64/python2.7/site-packages/calculate/update/variables/update.py", line 422, in get
ini = SystemIni(self.parent)
File "/usr/lib64/python2.7/site-packages/calculate/lib/cl_template.py", line 212, in __init

self.config.read(self.inifile, encoding="utf-8")
File "/usr/lib64/python2.7/site-packages/calculate/lib/configparser.py", line 719, in read
self._read(fp, filename)
File "/usr/lib64/python2.7/site-packages/calculate/lib/configparser.py", line 1193, in _read
raise e
ParsingError: Source contains parsing errors: /var/lib/calculate/ini.env
[line 62]: u'nlevels]\n' * sync_reps_fallback:ParsingError:Source contains parsing errors: /var/lib/calculate/ini.env * [line 62]: u'nlevels]\n'(calculate.lib.configparser:1193) * Update failed

I have never had problems like this before. Any assistance would be greatly appreciated. I usually update every week and this problem surfaced about 3-4 weeks ago.


Replies (5)

RE: cl-update fails with python 2.7 errors - Added by Adrien Daugabel 4 months ago

Hi,
Can you show the file with :

cat /var/lib/calculate/ini.env

without problems?

The cl-update tool can't read the file. Is it corrupted ?

RE: cl-update fails with python 2.7 errors - Added by Robert Stockdale 4 months ago

The ini.env file is as follows:

bob@calculate ~/Documents $ cat /var/lib/calculate/ini.env
[overlay-calculate]
remerge = 20170629.1
world = 7
revision = 20170629

[overlay-distros]
revision = 4
world = 20170628.1
remerge = 6

[merge-calculate]
utils = 3.5.4.2
desktop = 3.5.4.2
client = 3.5.4.2
qt4 = 3.4.7.19

[runlevels]
cups = on
calculate-utils/calculate-core = on
dbus = on
openrc/consolefont = on
consolekit = on
eudev = on
vixie-cron = on
splashutils = on
syslog-ng = on
openssh = on
bluez = on
openrc/numlock = on
lvm2 = on
mdadm = on
udev-init-scripts = on
fuse = on
alsa-utils = on

[desktop]
terminal = mate-terminal
textedit = pluma
imageview = eom
chat = hexchat
imageedit = gimp
audioplayer = clementine
writer = libreoffice
calc = libreoffice
videoplayer = smplayer
bluez = on
openrc/numlock = on
preload = on
lvm2 = on
mdadm = on
imageburn = brasero
im = pidgin
mail = claws-mail
browser = firefox
calculator = mate-calc

[system]
last_update = 1498750896
last_check = 1498879796
own_cache = distros,calculate

nlevels]
cups = on
calculate-utils/calculate-core = on
dbus = on
openrc/consolefont = on
consolekit = on
eudev = on
vixie-cron = on
splashutils = on
syslog-ng = on
openssh = on
bluez = on
openrc/numlock = on
lvm2 = on
mdadm = on
udev-init-scripts = on
fuse = on
alsa-utils = on

[desktop]
terminal = mate-terminal
textedit = pluma
imageview = eom
chat = hexchat
imageedit = gimp
audioplayer = clementine
writer = libreoffice
calc = libreoffice
videoplayer = smplayer
bluez = on
openrc/numlock = on
preload = on
lvm2 = on
mdadm = on
imageburn = brasero
im = pidgin
mail = claws-mail
browser = firefox
calculator = mate-calc

[system]
last_update = 1498750896
last_check = 1498879796
own_cache = distros,calculate

What file is cl-update trying to read? If it is corrupt, how do I replace it with one that isn't corrupt?

RE: cl-update fails with python 2.7 errors - Added by Adrien Daugabel 4 months ago

I think there are a problem here :

nlevels]

It's not nlevels] but [runlevels]

Edit this file in command line with nano for example or vi, and change the nlevels] by [runlevels] ith root user.

Backup your original file before with

cp /var/lib/calculate/ini.env  /var/lib/calculate/ini.env.bak

RE: cl-update fails with python 2.7 errors - Added by Robert Stockdale 4 months ago

Thanks. It was the problem. Updating now. Wish I knew how this file got changed. Thanks again!

RE: cl-update fails with python 2.7 errors - Added by Adrien Daugabel 4 months ago

I don't know, it's very strange. But it's cool that it's solved :)

(1-5/5)

Thank you!