cl-update fails with kholidays

Added by Ying Si 4 months ago

cl-update fails with kholidays
----------------------------
[code]
plasma ~ # cl-update
Repositories synchronization * Checking Distros updates ... [ ok ] * Checking Calculate updates ... [ ok ] * Checking Gentoo updates ... [ ok ] * Synchronization finished
System configuration * Update server https://mirror.koddos.net/calculate-linux
Updating packages * Calculating dependencies ... * Listing packages for installation * Assistant to import PIM data from other applications into Akonadi (N) kde-apps/akonadi-import-wizard-17.12.3 (0 KiB) * Calendar support library (U) kde-apps/calendarsupport-17.12.3 (0 KiB) * Calendar viewer for KDE PIM (U) kde-apps/eventviews-17.12.3 (0 KiB) * Incidence editor for korganizer (U) kde-apps/incidenceeditor-17.12.3 (0 KiB) * KDE accounts providers (U) kde-apps/kaccounts-providers-17.12.3 (0 KiB) * Address book application based on KDE Frameworks (N) kde-apps/kaddressbook-17.12.3 (0 KiB) * Client library to access and handling of KAlarm calendar data (U) kde-apps/kalarmcal-17.12.3 (0 KiB) * Libraries for KDE PIM applications (U) kde-apps/kdepim-apps-libs-17.12.3 (0 KiB) * Runtime plugin collection to extend the functionality of KDE PIM (U) kde-apps/kdepim-runtime-17.12.3 (0 KiB) * Email client, supporting POP3 and IMAP mailboxes. (U) kde-apps/kmail-17.12.3 (0 KiB) * Assistant for KMail accounts configuration (U) kde-apps/kmail-account-wizard-17.12.3 (0 KiB) * Container application to unify several major PIM applications within one (U) kde-apps/kontact-17.12.3 (0 KiB) * Organizational assistant, providing calendars and other similar functionality (U) kde-apps/korganizer-17.12.3 (0 KiB) * KDE Telepathy account management kcm (U) kde-apps/ktp-accounts-kcm-17.12.3 (0 KiB) * KDE Telepathy notification handler (U) kde-apps/ktp-approver-17.12.3 (0 KiB) * KDE Telepathy authentication handler (U) kde-apps/ktp-auth-handler-17.12.3 (0 KiB) * KDE Telepathy audio/video conferencing ui (U) kde-apps/ktp-call-ui-17.12.3 (0 KiB) * KDE Telepathy contact list (U) kde-apps/ktp-contact-list-17.12.3 (0 KiB) * KDE Telepathy krunner plugin (U) kde-apps/ktp-contact-runner-17.12.3 (0 KiB) * KDE Telepathy file transfer handler (U) kde-apps/ktp-filetransfer-handler-17.12.3 (0 KiB) * KDE Telepathy workspace integration (U) kde-apps/ktp-kded-module-17.12.3 (0 KiB) * KDE Telepathy file manager plugin to send files to contacts (U) kde-apps/ktp-send-file-17.12.3 (0 KiB) * KDE Telepathy text chat window (U) kde-apps/ktp-text-ui-17.12.3 (0 KiB) * Library for gravatar integration (U) kde-apps/libgravatar-17.12.3 (0 KiB) * Common PIM libraries (U) kde-apps/libksieve-17.12.3 (0 KiB) * Common mail library (U) kde-apps/mailcommon-17.12.3 (0 KiB) * Library to import mail from various sources (U) kde-apps/mailimporter-17.12.3 (0 KiB) * Libraries for messaging functions (U) kde-apps/messagelib-17.12.3 (0 KiB) * Assistant to backup and archive PIM data and configuration (N) kde-apps/pim-data-exporter-17.12.3 (0 KiB) * Common PIM libraries (U) kde-apps/pimcommon-17.12.3 (0 KiB) * Plasma Telepathy client (U) kde-apps/plasma-telepathy-meta-17.12.3 (0 KiB) * Library to determine holidays and other special events for a geographical region (N) kde-frameworks/kholidays-5.46.0 (0 KiB) * Extra Plasma applets and engines (U) kde-plasma/kdeplasma-addons-5.12.5 (0 KiB) * KDE Plasma workspace hotkey module (U) kde-plasma/khotkeys-5.12.5 (0 KiB) * KDE Plasma menu editor (U) kde-plasma/kmenuedit-5.12.5 (0 KiB) * KDE Plasma desktop (U) kde-plasma/plasma-desktop-5.12.5-r1 (0 KiB) * Merge this to pull in all Plasma 5 packages (U) kde-plasma/plasma-meta-5.12.5 (0 KiB) * KDE Plasma workspace (U) kde-plasma/plasma-workspace-5.12.5 (0 KiB) * Power management for KDE Plasma Shell (U) kde-plasma/powerdevil-5.12.5 (0 KiB) * NetworkManager OpenVPN plugin (U) net-misc/networkmanager-openvpn-1.8.2 (0 KiB) * NetworkManager PPTP plugin (U) net-misc/networkmanager-pptp-1.2.4 (0 KiB) * NetworkManager VPNC plugin (U) net-misc/networkmanager-vpnc-1.2.4 (0 KiB) * Powerful BitTorrent client based on KDE Frameworks (U) net-p2p/ktorrent-5.1.0 (0 KiB) * Virtual for notification daemon dbus service (rR) virtual/notification-daemon-0 (0 KiB) * Listing packages for removal * kde-apps/kde-l10n-16.12.0 * kde-apps/kde4-l10n-16.12.0 * kde-apps/kdepim-l10n-16.12.0 * kde-apps/kholidays-16.12.0 * 44 packages will be installed, 0 KiB will be downloaded

Would you like to merge these packages? (Yes/No): * (1 of 44) NetworkManager VPNC plugin * Emerging net-misc/networkmanager-vpnc-1.2.4 ... [ ok ] * (2 of 44) NetworkManager PPTP plugin * Emerging net-misc/networkmanager-pptp-1.2.4 ... [ ok ] * (3 of 44) NetworkManager OpenVPN plugin * Emerging net-misc/networkmanager-openvpn-1.8.2 ... [ ok ] * (4 of 44) Library to determine holidays and other special events for a geographical region * Emerging kde-frameworks/kholidays-5.46.0 ... [ ok ] * Installing net-misc/networkmanager-pptp-1.2.4 [1.2.2] ... [ ok ] * (5 of 44) Common PIM libraries * Emerging kde-apps/pimcommon-17.12.3 ... [ ok ] * Installing net-misc/networkmanager-openvpn-1.8.2 [1.2.4] ... [ ok ] * (6 of 44) KDE Telepathy contact list * Emerging kde-apps/ktp-contact-list-17.12.3 ... [ ok ] * Installing net-misc/networkmanager-vpnc-1.2.4 [1.2.2] ... [ ok ] * (7 of 44) Library to import mail from various sources * Emerging kde-apps/mailimporter-17.12.3 ... [ ok ] * Installing kde-frameworks/kholidays-5.46.0 ... [ ok ] * (8 of 44) KDE Telepathy file transfer handler * Emerging kde-apps/ktp-filetransfer-handler-17.12.3 ... [ ok ] * (9 of 44) KDE Telepathy audio/video conferencing ui * Emerging kde-apps/ktp-call-ui-17.12.3 ... [ ok ] * (10 of 44) KDE Telepathy authentication handler * Emerging kde-apps/ktp-auth-handler-17.12.3 ... [ ok ] * (11 of 44) KDE Telepathy workspace integration * Emerging kde-apps/ktp-kded-module-17.12.3 ... [ ok ] * (12 of 44) KDE Telepathy krunner plugin * Emerging kde-apps/ktp-contact-runner-17.12.3 ... [ ok ] * Installing kde-apps/pimcommon-17.12.3 [16.12.0] ... [ ok ] * Installing kde-apps/ktp-contact-list-17.12.3 [16.12.0] ... [ ok ] * Installing kde-apps/mailimporter-17.12.3 [16.12.0] ... [ ok ] * Installing kde-apps/ktp-filetransfer-handler-17.12.3 [16.12.0] ... [ ok ] * Installing kde-apps/ktp-call-ui-17.12.3 [16.12.0] ... [ ok ] * Installing kde-apps/ktp-auth-handler-17.12.3 [16.12.0] ... [ ok ] * Installing kde-apps/ktp-kded-module-17.12.3 [16.12.0] ... [ ok ] * Installing kde-apps/ktp-contact-runner-17.12.3 [16.12.0] ... [ ok ] * used by /usr/lib64/libplasma.so.3.0.0 (kde-frameworks/kdelibs-4.14.24)

package: sys-libs/readline-7.0_p3

* - /lib64/libreadline.so.6 * - /lib64/libreadline.so.6.3 * used by /usr/lib64/libguilereadline-v-17.so.17.0.3 (dev-scheme/guile-1.8.8-r3) * used by /usr/lib64/python3.4/lib-dynload/readline.cpython-34m.so (dev-lang/python-3.4.5) * used by /usr/lib64/ruby/2.1.0/x86_64-linux/readline.so (dev-lang/ruby-2.1.9)

package: sys-libs/ncurses-6.1-r2

* - /lib64/libtinfow.so.5 * - /lib64/libtinfow.so.5.9 * - /lib64/libtinfo.so.5 * - /lib64/libtinfo.so.5.9 * used by /lib64/libreadline.so.6 (preserved) * used by /lib64/libreadline.so.6.3 (preserved) * - /lib64/libncursesw.so.5 * - /lib64/libncursesw.so.5.9 * used by /usr/lib64/python3.4/lib-dynload/_curses.cpython-34m.so (dev-lang/python-3.4.5) * - /usr/lib64/libpanelw.so.5 * - /usr/lib64/libpanelw.so.5.9 * used by /usr/lib64/python3.4/lib-dynload/_curses_panel.cpython-34m.so (dev-lang/python-3.4.5)

package: sys-auth/polkit-qt-0.112.0_p20160416-r2

* - /usr/lib64/libpolkit-qt-core-1.so.1 * - /usr/lib64/libpolkit-qt-core-1.so.1.112.0 * used by /usr/lib64/kde4/plugins/kauth/backend/kauth_backend_plugin.so (kde-frameworks/kdelibs-4.14.24)
Use emerge @preserved-rebuild to rebuild packages using these libraries * Use eselect news read to view new items. * After world updates, it is important to remove obsolete packages with * emerge -depclean. Refer to `man emerge` for more information.
--------
* Emerge failed * Update failed [/code]
-------------------------
.
.
.
.
kholidays is not shown here but cl-update fails surely
.
.
..
.
catching the failure
.
.
. * Installing net-libs/signon-ui-0.15-r1 [0.15] ... [ ok ] * Installing kde-plasma/kwrited-5.12.5 [5.8.5] ... [ ok ] * Installing kde-frameworks/kholidays-5.46.0 ... [ ok ] * - /usr/lib64/libIlmImf-Imf_2_1.so.21.0.0 * used by /usr/lib64/kde4/plugins/imageformats/kimg_exr.so (kde-frameworks/kdelibs-4.14.24) * used by /usr/lib64/qt5/plugins/exrthumbnail.so (kde-apps/kio-extras-16.12.0)

package: media-libs/ilmbase-2.2.0-r1

* - /usr/lib64/libIlmThread-2_1.so.11 * - /usr/lib64/libIlmThread-2_1.so.11.0.0 * used by /usr/lib64/libIlmImf-Imf_2_1.so.21 (preserved) * used by /usr/lib64/libIlmImf-Imf_2_1.so.21.0.0 (preserved) * - /usr/lib64/libHalf.so.11 * - /usr/lib64/libHalf.so.11.0.0 * used by /usr/lib64/kde4/plugins/imageformats/kimg_exr.so (kde-frameworks/kdelibs-4.14.24) * - /usr/lib64/libIex-2_1.so.11 * - /usr/lib64/libIex-2_1.so.11.0.0 * used by /usr/lib64/kde4/plugins/imageformats/kimg_exr.so (kde-frameworks/kdelibs-4.14.24)

package: net-libs/gnutls-3.5.18

* - /usr/lib64/libgnutls.so.28 * - /usr/lib64/libgnutls.so.28.41.16 * used by /usr/sbin/vpnc (net-vpn/vpnc-0.5.3_p550)

package: sys-libs/readline-7.0_p3

* - /lib64/libreadline.so.6 * - /lib64/libreadline.so.6.3 * used by /usr/lib64/libguilereadline-v-17.so.17.0.3 (dev-scheme/guile-1.8.8-r3) * used by /usr/lib64/python3.4/lib-dynload/readline.cpython-34m.so (dev-lang/python-3.4.5) * used by /usr/lib64/ruby/2.1.0/x86_64-linux/readline.so (dev-lang/ruby-2.1.9)
Use emerge @preserved-rebuild to rebuild packages using these libraries * Use eselect news read to view new items. * After world updates, it is important to remove obsolete packages with * emerge --depclean. Refer to `man emerge` for more information. * Emerge failed * Update failed
guest@plasma ~ $
-----------
.
.
.
.

Edit2

[code]
Installing kde-frameworks/kholidays-5.46.0 ... [ ok ] * - /usr/lib64/libIlmImf-Imf_2_1.so.21.0.0 * used by /usr/lib64/kde4/plugins/imageformats/kimg_exr.so (kde-frameworks/kdelibs-4.14.24) * used by /usr/lib64/qt5/plugins/exrthumbnail.so (kde-apps/kio-extras-16.12.0)

package: media-libs/ilmbase-2.2.0-r1

* - /usr/lib64/libIlmThread-2_1.so.11 * - /usr/lib64/libIlmThread-2_1.so.11.0.0 * used by /usr/lib64/libIlmImf-Imf_2_1.so.21 (preserved) * used by /usr/lib64/libIlmImf-Imf_2_1.so.21.0.0 (preserved) * - /usr/lib64/libHalf.so.11 * - /usr/lib64/libHalf.so.11.0.0 * used by /usr/lib64/kde4/plugins/imageformats/kimg_exr.so (kde-frameworks/kdelibs-4.14.24) * - /usr/lib64/libIex-2_1.so.11 * - /usr/lib64/libIex-2_1.so.11.0.0 * used by /usr/lib64/kde4/plugins/imageformats/kimg_exr.so (kde-frameworks/kdelibs-4.14.24)

package: net-libs/gnutls-3.5.18

* - /usr/lib64/libgnutls.so.28 * - /usr/lib64/libgnutls.so.28.41.16 * used by /usr/sbin/vpnc (net-vpn/vpnc-0.5.3_p550)

package: sys-libs/readline-7.0_p3

* - /lib64/libreadline.so.6 * - /lib64/libreadline.so.6.3 * used by /usr/lib64/libguilereadline-v-17.so.17.0.3 (dev-scheme/guile-1.8.8-r3) * used by /usr/lib64/python3.4/lib-dynload/readline.cpython-34m.so (dev-lang/python-3.4.5) * used by /usr/lib64/ruby/2.1.0/x86_64-linux/readline.so (dev-lang/ruby-2.1.9)
Use emerge @preserved-rebuild to rebuild packages using these libraries * Use eselect news read to view new items. * After world updates, it is important to remove obsolete packages with * emerge --depclean. Refer to `man emerge` for more information. * Emerge failed * Update failed
guest@plasma ~ $
[/code]

Replies (3)

RE: cl-update fails with kholidays - Added by Ying Si 4 months ago

Just a suggestion:
Can you please update forum to bbc-code

RE: cl-update fails with kholidays - Added by Adrien Daugabel 4 months ago

Hi,
please, can you paste the result of the console on http://pastebin.calculate-linux.org/
it's better than forum to read :)
When did you do th last update ?

RE: cl-update fails with kholidays - Added by Ying Si 4 months ago

It was a clean 17.6 install
I have tried 17.12.2 install as well but network is not activated
-----------

Some Problem with the captcha to pastebin: It is not readable

(1-3/3)

Thank you!