Teamviewer has no gui after the start

Added by sasa brks 2 months ago

Teamviewer has no gui after launch, version 13.2.13582.

~ $ teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

~ $ teamviewer --info
TeamViewer                           13.2.13582  (TAR_IN)
TeamViewer ID:                        1081451067
teamviewerd status                    * status: started

Solution ?


Replies (19)

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

Today I did an update CLD and the program stopped working
Teamviewer has no gui after launch, version 13.2.13582

[code]
/opt/teamviewer/tv_bin/script/teamviewer
Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...[/code]

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

update packet before teamviewer stop work

quiet-build=n -verbose --getbinpkg --usepkg @world
1539369197: >>> emerge (1 of 14) sys-process/audit-2.8.3 to /
1539369197: >>> emerge (2 of 14) app-arch/zstd-1.3.4-r1 to /
1539369197: >>> emerge (3 of 14) media-libs/assimp-4.0.1 to /
1539369197: >>> emerge (4 of 14) media-sound/apulse-0.1.12_p20180803 to /
1539369197: --
(2 of 14) Fetching Binary (app-arch/zstd-1.3.4-r1::/var/calculate/packages/x86_64/app-arch/zstd-1.3.4-r1.tbz2.partial)
1539369197: --- (3 of 14) Fetching Binary (media-libs/assimp-4.0.1::/var/calculate/packages/x86_64/media-libs/assimp-4.0.1.tbz2.partial)
1539369197: --- (4 of 14) Fetching Binary (media-sound/apulse-0.1.12_p20180803::/var/calculate/packages/x86_64/media-sound/apulse-0.1.12_p20180803.tbz2.partial)
1539369198: === (4 of 14) Merging Binary (media-sound/apulse-0.1.12_p20180803::/var/calculate/packages/x86_64/media-sound/apulse-0.1.12_p20180803.tbz2)
1539369200: === (3 of 14) Merging Binary (media-libs/assimp-4.0.1::/var/calculate/packages/x86_64/media-libs/assimp-4.0.1.tbz2)
1539369201: === (2 of 14) Merging Binary (app-arch/zstd-1.3.4-r1::/var/calculate/packages/x86_64/app-arch/zstd-1.3.4-r1.tbz2)
1539369201: === (1 of 14) Merging Binary (sys-process/audit-2.8.3::/var/calculate/packages/x86_64/sys-process/audit-2.8.3.tbz2)
1539369203: >>> emerge (5 of 14) media-video/recordmydesktop-0.3.8.1-r6 to /
1539369203: === (5 of 14) Merging Binary (media-video/recordmydesktop-0.3.8.1-r6::/var/calculate/packages/x86_64/media-video/recordmydesktop-0.3.8.1-r6.tbz2)
1539369204: >>> emerge (6 of 14) dev-java/icedtea-bin-3.9.0 to /
1539369205: >>> emerge (7 of 14) dev-vcs/git-2.18.1 to /
1539369205: === (6 of 14) Merging Binary (dev-java/icedtea-bin-3.9.0::/var/calculate/packages/x86_64/dev-java/icedtea-bin-3.9.0.tbz2)
1539369205: --- (7 of 14) Fetching Binary (dev-vcs/git-2.18.1::/var/calculate/packages/x86_64/dev-vcs/git-2.18.1.tbz2.partial)
1539369206: >>> emerge (8 of 14) media-tv/kodi-17.6-r6 to /
1539369206: --- (8 of 14) Fetching Binary (media-tv/kodi-17.6-r6::/var/calculate/packages/x86_64/media-tv/kodi-17.6-r6.tbz2.partial)
1539369207: === (7 of 14) Merging Binary (dev-vcs/git-2.18.1::/var/calculate/packages/x86_64/dev-vcs/git-2.18.1.tbz2)
1539369209: === (8 of 14) Merging Binary (media-tv/kodi-17.6-r6::/var/calculate/packages/x86_64/media-tv/kodi-17.6-r6.tbz2)
1539369209: >>> emerge (9 of 14) media-video/vlc-3.0.4 to /
1539369209: --- (9 of 14) Fetching Binary (media-video/vlc-3.0.4::/var/calculate/packages/x86_64/media-video/vlc-3.0.4.tbz2.partial)
1539369212: === (9 of 14) Merging Binary (media-video/vlc-3.0.4::/var/calculate/packages/x86_64/media-video/vlc-3.0.4.tbz2)
1539369212: >>> emerge (10 of 14) media-libs/opencv-3.4.1-r4 to /
1539369213: === (10 of 14) Merging Binary (media-libs/opencv-3.4.1-r4::/var/calculate/packages/x86_64/media-libs/opencv-3.4.1-r4.tbz2)
1539369220: >>> AUTOCLEAN: media-sound/apulse:0
1539369222: >>> AUTOCLEAN: media-libs/assimp:0
1539369224: >>> AUTOCLEAN: app-arch/zstd:0
1539369224: === Unmerging... (app-arch/zstd-1.3.2)
1539369225: >>> AUTOCLEAN: sys-process/audit:0
1539369229: >>> unmerge success: app-arch/zstd-1.3.2
1539369232: === (4 of 14) Post-Build Cleaning (media-sound/apulse-0.1.12_p20180803::/var/calculate/packages/x86_64/media-sound/apulse-0.1.12_p20180803.tbz2)
1539369232: ::: completed emerge (4 of 14) media-sound/apulse-0.1.12_p20180803 to /
1539369235: === (1 of 14) Post-Build Cleaning (sys-process/audit-2.8.3::/var/calculate/packages/x86_64/sys-process/audit-2.8.3.tbz2)
1539369235: ::: completed emerge (1 of 14) sys-process/audit-2.8.3 to /
1539369235: >>> emerge (11 of 14) sys-auth/elogind-238.1 to /
1539369235: === (11 of 14) Merging Binary (sys-auth/elogind-238.1::/var/calculate/packages/x86_64/sys-auth/elogind-238.1.tbz2)
1539369237: === (3 of 14) Post-Build Cleaning (media-libs/assimp-4.0.1::/var/calculate/packages/x86_64/media-libs/assimp-4.0.1.tbz2)
1539369237: ::: completed emerge (3 of 14) media-libs/assimp-4.0.1 to /
1539369237: >>> emerge (12 of 14) dev-qt/qt3d-5.9.6 to /
1539369237: === (12 of 14) Merging Binary (dev-qt/qt3d-5.9.6::/var/calculate/packages/x86_64/dev-qt/qt3d-5.9.6.tbz2)
1539369239: === (2 of 14) Post-Build Cleaning (app-arch/zstd-1.3.4-r1::/var/calculate/packages/x86_64/app-arch/zstd-1.3.4-r1.tbz2)
1539369239: ::: completed emerge (2 of 14) app-arch/zstd-1.3.4-r1 to /
1539369240: >>> AUTOCLEAN: media-video/recordmydesktop:0
1539369240: === Unmerging... (media-video/recordmydesktop-0.3.8.1-r5)
1539369243: >>> AUTOCLEAN: dev-vcs/git:0
1539369243: === Unmerging... (dev-vcs/git-2.18.0)
1539369245: >>> AUTOCLEAN: dev-java/icedtea-bin:8
1539369245: === Unmerging... (dev-java/icedtea-bin-3.8.0)
1539369249: >>> AUTOCLEAN: media-tv/kodi:0
1539369249: === Unmerging... (media-tv/kodi-17.6-r5)
1539369249: >>> unmerge success: media-video/recordmydesktop-0.3.8.1-r5
1539369253: >>> unmerge success: dev-vcs/git-2.18.0
1539369256: >>> unmerge success: dev-java/icedtea-bin-3.8.0
1539369257: >>> unmerge success: media-tv/kodi-17.6-r5
1539369260: === (5 of 14) Post-Build Cleaning (media-video/recordmydesktop-0.3.8.1-r6::/var/calculate/packages/x86_64/media-video/recordmydesktop-0.3.8.1-r6.tbz2)
1539369260: ::: completed emerge (5 of 14) media-video/recordmydesktop-0.3.8.1-r6 to /
1539369264: === (7 of 14) Post-Build Cleaning (dev-vcs/git-2.18.1::/var/calculate/packages/x86_64/dev-vcs/git-2.18.1.tbz2)
1539369264: ::: completed emerge (7 of 14) dev-vcs/git-2.18.1 to /
1539369266: === (6 of 14) Post-Build Cleaning (dev-java/icedtea-bin-3.9.0::/var/calculate/packages/x86_64/dev-java/icedtea-bin-3.9.0.tbz2)
1539369266: ::: completed emerge (6 of 14) dev-java/icedtea-bin-3.9.0 to /
1539369275: === (8 of 14) Post-Build Cleaning (media-tv/kodi-17.6-r6::/var/calculate/packages/x86_64/media-tv/kodi-17.6-r6.tbz2)
1539369275: ::: completed emerge (8 of 14) media-tv/kodi-17.6-r6 to /
1539369276: >>> AUTOCLEAN: media-libs/opencv:0
1539369276: === Unmerging... (media-libs/opencv-3.4.1-r4)
1539369278: >>> AUTOCLEAN: sys-auth/elogind:0
1539369281: >>> AUTOCLEAN: media-video/vlc:0
1539369281: === Unmerging... (media-video/vlc-3.0.3-r1)
1539369285: >>> AUTOCLEAN: dev-qt/qt3d:5
1539369291: === (11 of 14) Post-Build Cleaning (sys-auth/elogind-238.1::/var/calculate/packages/x86_64/sys-auth/elogind-238.1.tbz2)
1539369291: ::: completed emerge (11 of 14) sys-auth/elogind-238.1 to /
1539369291: >>> emerge (13 of 14) net-im/skypeforlinux-8.31.0.92-r1 to /
1539369291: >>> unmerge success: media-libs/opencv-3.4.1-r4
1539369292: === (13 of 14) Merging Binary (net-im/skypeforlinux-8.31.0.92-r1::/var/calculate/packages/x86_64/net-im/skypeforlinux-8.31.0.92-r1.tbz2)
1539369292: === (12 of 14) Post-Build Cleaning (dev-qt/qt3d-5.9.6::/var/calculate/packages/x86_64/dev-qt/qt3d-5.9.6.tbz2)
1539369292: ::: completed emerge (12 of 14) dev-qt/qt3d-5.9.6 to /
1539369292: >>> emerge (14 of 14) net-im/viber-7.0.0.1035-r1 to /
1539369292: === (14 of 14) Merging Binary (net-im/viber-7.0.0.1035-r1::/var/calculate/packages/x86_64/net-im/viber-7.0.0.1035-r1.tbz2)
1539369294: >>> unmerge success: media-video/vlc-3.0.3-r1
1539369299: === (10 of 14) Post-Build Cleaning (media-libs/opencv-3.4.1-r4::/var/calculate/packages/x86_64/media-libs/opencv-3.4.1-r4.tbz2)
1539369299: ::: completed emerge (10 of 14) media-libs/opencv-3.4.1-r4 to /
1539369306: === (9 of 14) Post-Build Cleaning (media-video/vlc-3.0.4::/var/calculate/packages/x86_64/media-video/vlc-3.0.4.tbz2)
1539369306: ::: completed emerge (9 of 14) media-video/vlc-3.0.4 to /
1539369307: >>> AUTOCLEAN: net-im/skypeforlinux:0
1539369307: === Unmerging... (net-im/skypeforlinux-8.29.0.50)
1539369312: >>> AUTOCLEAN: net-im/viber:0
1539369312: === Unmerging... (net-im/viber-7.0.0.1035)
1539369313: >>> unmerge success: net-im/skypeforlinux-8.29.0.50
1539369320: >>> unmerge success: net-im/viber-7.0.0.1035
1539369320: === (13 of 14) Post-Build Cleaning (net-im/skypeforlinux-8.31.0.92-r1::/var/calculate/packages/x86_64/net-im/skypeforlinux-8.31.0.92-r1.tbz2)
1539369320: ::: completed emerge (13 of 14) net-im/skypeforlinux-8.31.0.92-r1 to /
1539369326: === (14 of 14) Post-Build Cleaning (net-im/viber-7.0.0.1035-r1::/var/calculate/packages/x86_64/net-im/viber-7.0.0.1035-r1.tbz2)
1539369326: ::: completed emerge (14 of 14) net-im/viber-7.0.0.1035-r1 to /
1539369326: * Finished. Cleaning up...
1539369330:
exiting successfully.
1539369330: *
* terminating.

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

Has anyone noticed a question and a problem for teamviewer 13? In other linux teamviewer 13 works normally. I have KDE-plasma Calculate, Sasa has XFCE Calculate. Teamviewer needs us to help other users Calculate linux.

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

What's happening? I started a manual update eix-sync, cl-update and he is trying to update the programs to an unstable version. Programs are looking for eg. dev-qt / qtgui 5.11.1 and these are parts of a newer version of plasma. Plasma is version 5.12.5 and its parts are e.g. dev-qt / qtgui 5.9.6. Granny and frog can not be mixed. All these addictions are needed for the teamviewer who does not work. The plasma must update to version 5.13.5 to use qt 5.11.1

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

Please help me
  1. required by dev-qt/qtgui-5.11.1::gentoo[dbus]
  2. required by dev-qt/qtwidgets-5.11.1::gentoo
  3. required by dev-qt/qtcharts-5.11.1::gentoo
  4. required by x11-apps/radeon-profile-20170714::frabjous
  5. required by @selected
  6. required by @world (argument)
    =dev-qt/qtdbus-5.11.1 ~amd64
  7. required by dev-qt/qtwidgets-5.11.1::gentoo
  8. required by dev-qt/qtcharts-5.11.1::gentoo
  9. required by x11-apps/radeon-profile-20170714::frabjous
  10. required by @selected
  11. required by @world (argument)
    =dev-qt/qtgui-5.11.1 ~amd64
  12. required by dev-libs/glib-2.56.2::gentoo
  13. required by dev-qt/qtgui-5.11.1::gentoo
  14. required by dev-qt/qtwidgets-5.11.1::gentoo
  15. required by dev-qt/qtcharts-5.11.1::gentoo
  16. required by x11-apps/radeon-profile-20170714::frabjous
  17. required by @selected
  18. required by @world (argument)
    =dev-util/glib-utils-2.56.2 ~amd64
  19. required by app-admin/system-config-printer-1.4.8::gentoo
  20. required by @selected
  21. required by @world (argument)
    =dev-libs/glib-2.56.2 ~amd64
  22. required by dev-qt/qtcharts-5.11.1::gentoo
  23. required by x11-apps/radeon-profile-20170714::frabjous
  24. required by @selected
  25. required by @world (argument)
    =dev-qt/qtwidgets-5.11.1 ~amd64 * Emerge failed * Update failed
  • Calculating dependencies ... [ ok ]
    [ebuild U ~] dev-util/glib-utils-2.56.2::gentoo [2.52.3::gentoo] PYTHON_SINGLE_TARGET="python3_6%* -python3_5% -python3_7%" PYTHON_TARGETS="python3_6%* -python3_5% -python3_7%" 7854 KiB
    [ebuild U ~] dev-libs/glib-2.56.2:2::gentoo [2.54.3-r6:2::gentoo] USE="dbus mime xattr -debug (-fam) (-selinux) -static-libs -systemtap -test -utils" ABI_X86="32 (64) (-x32)" PYTHON_SINGLE_TARGET="(-python2_7%) (-python3_5%) (-python3_6%) (-python3_7%)" PYTHON_TARGETS="(-python2_7%) (-python3_5%) (-python3_6%*) (-python3_7%)" 1886 KiB
    [blocks b ] <dev-libs/glib-2.56.2:2 ("<dev-libs/glib-2.56.2:2" is blocking dev-util/glib-utils-2.56.2)
    [binary N ] app-arch/gcab-0.8::gentoo USE="introspection -vala" 109 KiB
    [ebuild U ~] dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo [5.9.6:5/5.9::gentoo] USE="icu -debug (-systemd) -test" 45763 KiB
    [ebuild U ~] dev-qt/qtdbus-5.11.1:5/5.11::gentoo [5.9.6:5/5.9::gentoo] USE="-debug -test" 0 KiB
    [ebuild U ~] dev-qt/qtgui-5.11.1:5/5.11::gentoo [5.9.6:5/5.9::gentoo] USE="accessibility dbus egl gif jpeg libinput png udev xcb -debug -eglfs -evdev -gles2 -ibus -test -tslib -tuio -vnc" 0 KiB
    [binary N ] dev-libs/appstream-glib-0.6.13:0/8::gentoo USE="introspection nls -stemmer" 466 KiB
    [ebuild U ~] dev-qt/qtwidgets-5.11.1:5/5.11::gentoo [5.9.6-r1:5/5.9::gentoo] USE="gtk png xcb -debug -gles2 -test" 0 KiB
    [ebuild U ~] dev-qt/qtcharts-5.11.1:5/5.11::gentoo [5.9.6:5/5.9::gentoo] USE="-debug -qml -test" 4146 KiB
    [binary U ] dev-libs/volume_key-0.3.11::gentoo [0.3.9::gentoo] USE="-test" PYTHON_SINGLE_TARGET="python3_6 -python3_5 (-python3_7) (-python3_4%)" PYTHON_TARGETS="python3_6 -python3_5 (-python3_7) (-python3_4%)" 202 KiB
    [ebuild U ~] media-gfx/gimp-2.10.6-r1:2::gentoo [2.10.4:2::gentoo] USE="alsa jpeg2k openexr python smp udev webp wmf -aalib (-altivec) (-aqua) -debug -doc -gnome -heif% -mng -postscript -test -vector-icons -xpm" CPU_FLAGS_X86="mmx sse" PYTHON_TARGETS="python2_7" 30711 KiB
  • 11 packages will be installed, 91133 KiB will be downloaded

RE: Teamviewer has no gui after the start - Added by Alexander Tratsevskiy about 1 month ago

I tried to install - everything works fine. I am using CLDX 18. I attach a screenshot.

teamviewer.png (84.9 KB)

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

Thanks in the picture but Sasa has CLDX 18 and the teamviewer program worked only until the first update. The same situation is with me, the CLD 18 teamviewer program is running only until the first update, the program stops working, no GUI. Whether your install CLDX 18 is new or is to update it. Calculate is a RR distribution, Sasa and I have been working on a regular update to version 18. Now in that situation I have a new problem that nex update looks for files 5.11.1

RE: Teamviewer has no gui after the start - Added by sasa brks about 1 month ago

CLDX 18, 64 bit, after update not working Teamviewer.

Update

Started emerge on: Oct 07, 2018 22:49:04

emerge (1 of 11) dev-libs/vala-common-0.36.13
emerge (2 of 11) dev-libs/protobuf-c-1.3.0-r1
emerge (3 of 11) net-libs/libgadu-1.12.2
emerge (4 of 11) dev-lang/vala-0.36.13
emerge (5 of 11) net-libs/gssdp-1.0.2
emerge (6 of 11) net-libs/gupnp-1.0.2
emerge (7 of 11) net-libs/gupnp-igd-0.2.5
emerge (8 of 11) net-libs/libnice-0.1.13
emerge (9 of 11) media-plugins/gst-plugins-libnice-0.1.13-r100
emerge (10 of 11) net-libs/farstream-0.2.8-r1
emerge (11 of 11) net-im/pidgin-2.13.0

Started emerge on: Oct 08, 2018 10:20:48

emerge (1 of 10) dev-libs/libebml-1.3.5
emerge (2 of 10) net-libs/libmicrodns-0.0.9
emerge (3 of 10) media-libs/libdvbpsi-1.3.1
emerge (4 of 10) net-libs/libupnp-1.6.21
emerge (5 of 10) media-libs/libcuefile-477-r1
emerge (6 of 10) media-libs/libreplaygain-477-r1
emerge (7 of 10) sys-libs/libavc1394-0.5.4-r1
emerge (8 of 10) media-libs/libmatroska-1.4.8
emerge (9 of 10) media-sound/musepack-tools-465-r1
emerge (10 of 10) media-video/vlc-3.0.3-r1

Started emerge on: Oct 09, 2018 01:19:24

emerge (1 of 7) media-libs/libtheora-1.1.1-r2
emerge (2 of 7) net-libs/libtorrent-rasterbar-1.1.9
emerge (3 of 7) net-firewall/shorewall-5.2.0.5
emerge (4 of 7) sys-apps/usb_modeswitch-2.5.2
emerge (5 of 7) dev-python/notify2-0.3
emerge (6 of 7) x11-libs/libnotify-0.7.7-r1
emerge (7 of 7) net-print/hplip-3.18.6-r1

calculate_xfce.png (462.9 KB)

RE: Teamviewer has no gui after the start - Added by . vmolution about 1 month ago

I downloaded the extract version, running on LIVE CLDXFCE
https://download.teamviewer.com/download/linux/teamviewer_amd64.tar.xz

No GUI too, with the following error in gui.log

/home/guest/Downloads/teamviewer/tv_bin/TeamViewer: error while loading shared libraries: libQt5X11Extras.so.5: cannot open shared object file: No such file or directory

If using Version 12, live Calculate doesn't have wine inside,
the following from gui.log

fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (3): stub
fixme:msg:ChangeWindowMessageFilter 233 00000001
fixme:msg:ChangeWindowMessageFilter 4a 00000001
fixme:msg:ChangeWindowMessageFilter 407 00000001
fixme:msg:ChangeWindowMessageFilter 49 00000001
fixme:ver:GetCurrentPackageId (0x19de9f8 (nil)): stub
wine: Unhandled page fault on read access to 0xffffffff at address 0x7e4b59a1 (thread 0020), starting debugger...
err:seh:start_debugger Couldn't start debugger ("winedbg --auto 31 140") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

I have this file libQt5X11Extras.so.5 and qtx11extras can be installed 5.9.6. When I installed Teamviewer 13 he worked, then I did the update and the program stopped working. The identical situation in CLDX and CLD (kde-plasma) I did not try Version 12 because I do not have the offer, if it is downloaded from the Internet it is a version that searches 32bit libraries and Calculate KDE-plasma does not support more with the latest update to version 18 32bit programs. My gui.log is empty.

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

I can not believe that no one has a teamviewer solution. The answer to the program does not mean anything, I get such answers in forums where new users respond. I did not even get the answer whether the new installation was clean or it was updated on version 18. The menu was working on version 18 to the first update. I spent days and days of miners on the Internet looking for some clue, but for this distro a bit of what to find. I am very disappointed with the support, the forum does not work, I think that distro without support can not function.
Best wishes Dragan

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

I can not believe that no one has a teamviewer solution. The answer to the program does not mean anything, I get such answers in forums where new users respond. I did not even get the answer whether the new installation was clean or it was updated on version 18. The menu was working on version 18 to the first update. I spent days and days of miners on the Internet looking for some clue, but for this distro a bit of what to find. I am very disappointed with the support, the forum does not work, I think that distro without support can not function. I can no longer waste my time and lives searching for something that is not on the Internet, the program works in 5 other plasma distributions that I tried.
Best wishes Dragan

RE: Teamviewer has no gui after the start - Added by . vmolution about 1 month ago

Hi,
Do you have other information in your gui.log? Since you said you got libQt5X11Extras.so.5 and qtx11extras

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

I have nothing in the gui.log. I found information about the file based on your writing, started Dolphin and the serach name of that file. There is one file libQt5X11Extras.so.5.9.6 and more version eg. libQt5X11Extras.so.5 which are the links on libQt5X11Extras.so.5.9.6. Which source of this file I found on the Internet and checked with me that this is qtx11extras version 5.9.6. I repeat myself as a parrot Teamviewer worked when I installed it, stopped working after the Calculate update, I sent a list of all the files that were then installed. Sasa had an identical CLDX situation, and he had the files that were updating. So something does not mess with the update CLD and CLDX and teamviewer. Everything reminds me of the time 8 years ago when the successful installation of Google Earth in Debian or Ubuntu was a lottery. I had a version of Teamviewer 10 on CLD, it was even before installation problems, but the setup not to use system wine was a problem net-misc/teamviewer -system-wine. I think that something is happening here because the program is oriented to systemd.
Best wishes Dragan

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

. vmolution wrote:

Hi,
Do you have other information in your gui.log? Since you said you got libQt5X11Extras.so.5 and qtx11extras

  1. Copyright 1999-2018 Gentoo Foundation
  2. Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_PN=${PN}${PV/\.*}
inherit desktop gnome2-utils systemd

DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
HOMEPAGE="https://www.teamviewer.com"
SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.}x/${PN}${PV}_amd64.tar.xz )
x86? ( https://dl.tvcdn.de/download/linux/version
${PV/\.
}x/${PN}_${PV}_i386.tar.xz )"

LICENSE="TeamViewer MIT"
SLOT="${PV/\.}"
KEYWORDS="-
~amd64 ~x86"
IUSE=""

DEPEND="sys-apps/sed"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtquickcontrols:5
dev-qt/qtwebkit:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
sys-apps/dbus
"
--------------------------------
You can see the dependencies of the .ebuild file, but it's all debatable because it's obvious that all of these files depend on the version of the plasma and who knows which of the other files. The program is a closed source so I do not know the way to find out what it takes all to do what it feels for it to work normally.The program in other distributions eg. Manjaro, Arch, Neon, Kubuntu works quite normally and I never had a problem with the installation. The only difference is that all distributions have systemd.

https://pastebin.com/kR3parrU

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

I read Arch help and read incredible things. Teamviewer can only work with systemd, login manager lightdm and lib32-freetype2 version 2 . I have Manjaro who is Arch clone and plasma sddm login manager and plasma 5.14.0, systemd, freetype2 lib32 and lib64 and teamviewer13 work ok.

RE: Teamviewer has no gui after the start - Added by Jose Jurado about 1 month ago

Teamviewer 11 at least seems to be able to be started in Gentoo systems, which use OpenRC, not systemd, but then, if your findings are correct, you may have to look into whether lightdm and lib32-freetype2 v2 are challenges.

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

I had version 10 and she worked on KDE Plasma (CLD), I made a update to teamviewer 13 and he worked. After that, I did a system update and Teamviewer stopped working. Sasa had the same situation with CLDX. When looking at .ebuld version 12, 11, 10, etc., it seems that the dependencies that are not present in this version are 5.12.5 ie. Now, tonight updated plasma 5.13.5. I have read a lot of nebulous explanations, ARCH does not work, and teamviewer works in Arch. Neon, Manjaro, Kubuntu teamviewer work. To investigate what the update has done is Sisyphus's job. Using AnyDeskt works without any problems and this is an old version of layman overlay

RE: Teamviewer has no gui after the start - Added by dragan legic about 1 month ago

Start: 2018/10/26 23:35:57.391 (UTC+0:00)
Version: 13.2.13582
ID: 0
Loglevel: Info (100)
License: 0
Server: master2.teamviewer.com
IC: 2015728257
CPU: AMD FX(tm)-6100 Six-Core Processor
CPU extensions: e9
OS: Lx Calculate/Linux (x86_64)
IP:
MID: 2015728257_3773e1986_97d3f51533719d3e
MIDv: 0
Proxy-Settings: Type=0 IP= User=

2018/10/26 23:35:58.580 4690 140358701890368 S!! NetWatchDogLinux: Cannot enumerate inital network state, (DBus: 'org.freedesktop.DBus.Error.NoReply' (Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.) when calling 'org.freedesktop.DBus.Properties.Get' on '/org/freedesktop/NetworkManager'), Errorcode=11
2018/10/26 23:35:58.580 4690 140358701890368 S NetWatchDogLinux: using RTLink event handler
2018/10/26 23:35:58.581 4690 140358701890368 S NetWatchdog: LAN is now disconnected
2018/10/26 23:35:58.581 4690 140358701890368 S RemoteSettingsMDRelationshipWatchDog: DEVICE ISN'T A MANAGED DEVICE
2018/10/26 23:35:58.581 4690 140357576681216 S RemoteSettingsStore: Cleanup all policies.
2018/10/26 23:35:58.581 4690 140358701890368 S RemoteSettingsStoreListener: Establish connection.
2018/10/26 23:35:58.581 4690 140357576681216 S RemoteSettingsStore::LoadLastReceivedPolicies : Storage Entry Remote_Settings_TVClientSetting_Policy empty
2018/10/26 23:35:58.581 4690 140358701890368 S Using IPC-Port 5939
2018/10/26 23:35:58.582 4690 140357576681216 S RemoteSettingsMDRelationshipWatchDog: DEVICE ISN'T A MANAGED DEVICE
2018/10/26 23:35:58.582 4690 140358680082176 S OSSessionEventTranslatorLinux::RegisterSessionEven ts(): Start observing session events
2018/10/26 23:35:58.582 4690 140358680082176 S OSSessionEventTranslator::GenerateEventsForSession : SessionID = 4294967295, username = , primarySession = 0, unusable = 0, locked = 0, connected = 0
2018/10/26 23:35:58.582 4690 140358680082176 S OSSessionEventTranslator::GenerateEventsForSession : SessionID = 4294967295, username = , primarySession = 0, unusable = 0, locked = 0, connected = 0
2018/10/26 23:35:58.582 4690 140358680082176 S OSSessionEventTranslator::GenerateEventsForSession : SessionID = 3033812221, username = , primarySession = 1, unusable = 1, locked = 0, connected = 1
2018/10/26 23:35:58.582 4690 140358680082176 S OSSessionEventTranslator::GenerateEventsForSession : SessionID = 3510599056, username = root, primarySession = 0, unusable = 0, locked = 0, connected = 0
2018/10/26 23:35:58.582 4690 140358680082176 S UpdateOnlineState alwaysOnline=0 modifiedOnline=0 otherProcess=0 restart=0
2018/10/26 23:36:04.561 4690 140357585073920 S NetWatchdog: LAN is now connected
2018/10/26 23:36:04.561 4690 140358591706880 S CKeepAliveClientClient::HandleStartKeepAlive: doing nothing, online state = 2
2018/10/26 23:57:39.322 4690 140358016853760 S SysSession updated: SysSession 3510599056 [type=70 vt=16 tty=/dev/tty0 pseudotty=0 info=1 id=/dev/fb0 user=root state=greeter active=0 reliable=1]
2018/10/26 23:57:39.322 4690 140358016853760 S OSSessionEventTranslatorLinux::SessionUpdated: old osSessionID: 3510599056 username: root userLoggedIn: 0 locked: 0 primarySession: 0 unusableState: 0 connected: 0
2018/10/26 23:57:39.322 4690 140358016853760 S OSSessionEventTranslatorLinux::SessionUpdated: new osSessionID: 3510599056 username: root userLoggedIn: 0 locked: 0 primarySession: 0 unusableState: 0 connected: 0
2018/10/26 23:57:39.517 4690 140358701890368 S Process received SIGTERM from process: 11039
2018/10/26 23:57:39.517 4690 140358701890368 S ShutdownDynGate
2018/10/26 23:57:39.518 4690 140358566528768 S CAcceptServer::HandleAccept: socket closed
2018/10/26 23:57:39.545 4690 140357585073920 S NetworkEventLinux: shutting down (0)
2018/10/26 23:57:39.546 4690 140358701890368 S Shutting down System DBus
2018/10/26 23:57:39.566 4690 140358035830528 S XSocket observer: thread_interrupted
2018/10/26 23:57:39.568 4690 140357559895808 S Shutdown complete
2018/10/26 23:57:39.568 4690 140358701890368 S TeamViewer_Service Stop

2018/10/27 08:25:19.966 4714 139755021654848 S Logger started.
2018/10/27 08:25:20.422 4714 139755021654848 S Found 0 core dump files ...
2018/10/27 08:25:20.427 4714 139754999838464 S+ Thread: SystemBusIO0
2018/10/27 08:25:20.427 4714 139754991445760 S+ Thread: SystemBusIO1
2018/10/27 08:25:20.586 4714 139755021654848 S Shutting down System DBus
2018/10/27 08:25:20.586 4714 139754983053056 S+ Thread: IOServiceWorker_2
2018/10/27 08:25:20.586 4714 139754991445760 S+ Thread: IOServiceWorker_0
2018/10/27 08:25:20.586 4714 139754966267648 S+ Thread: IOServiceWorker_4
2018/10/27 08:25:20.587 4714 139754999838464 S+ Thread: IOServiceWorker_1
2018/10/27 08:25:20.587 4714 139754957874944 S+ Thread: IOServiceWorker_5
2018/10/27 08:25:20.587 4714 139755021654848 S SysSessionInfoManager: observing sessions from logind is marked as unreliable
2018/10/27 08:25:20.587 4714 139754974660352 S+ Thread: IOServiceWorker_3
2018/10/27 08:25:20.587 4714 139754746148608 S+ Thread: SystemBusIO0
2018/10/27 08:25:20.587 4714 139754737755904 S+ Thread: SystemBusIO1
2018/10/27 08:25:20.742 4714 139755021654848 S!! ConsoleKitSeat: error getting active session [DBus: 'org.freedesktop.ConsoleKit.Seat.Error.NoActiveSes sion' (Seat has no active session) when calling 'org.freedesktop.ConsoleKit.Seat.GetActiveSession' on '/org/freedesktop/ConsoleKit/Seat1'], Errorcode=2
2018/10/27 08:25:20.743 4714 139755021654848 S SysSessionInfoManager: Session Information provided by ConsoleKit [priority: 1]
2018/10/27 08:25:20.744 4714 139755021654848 S SysSessionInfoManager: Session Information provided by VT [priority: 2]
2018/10/27 08:25:20.745 4714 139755021654848 S+ LateBinding [libX11.so.6]: Loaded library
2018/10/27 08:25:20.745 4714 139755021654848 S XSocket observer: watching /tmp/.X11-unix
2018/10/27 08:25:20.778 4714 139755021654848 S XSocket observer: adding XSession '3036032522' for display 0
2018/10/27 08:25:20.781 4714 139755021654848 S SysSessionInfoManager: assigned session 3036032522 to info provider 'VT'
2018/10/27 08:25:20.827 4714 139755021654848 S Starting as daemon
2018/10/27 08:25:20.865 4714 139755021654848 S! No method for suspend/resume monitoring found
2018/10/27 08:25:20.909 4714 139755021654848 S! AsioSettings::FindExternalIP: found 0 external IPs instead of 1!
2018/10/27 08:25:20.919 4714 139755021654848 S UpdateOnlineState alwaysOnline=0 modifiedOnline=0 otherProcess=0 restart=0
2018/10/27 08:25:20.919 4714 139755021654848 S+ tvnetwork::Offline: online state 0
2018/10/27 08:25:20.920 4714 139755021654848 S! AsioSettings::FindExternalIP: found 0 external IPs instead of 1!
2018/10/27 08:25:20.923 4714 139755021654848 S System uptime: 25 seconds
2018/10/27 08:25:20.924 4714 139755021654848 S SystemID m=1 s=0 b369437c96867904854e9e88001e57b8

Start: 2018/10/27 08:25:20.924 (UTC+0:00)
Version: 13.2.13582
ID: 0
Loglevel: Info (100)
License: 0
Server: master9.teamviewer.com
IC: 2015728257
CPU: AMD FX(tm)-6100 Six-Core Processor
CPU extensions: e9
OS: Lx Calculate/Linux (x86_64)
IP:
MID: 2015728257_3773e1986_97d3f51533719d3e
MIDv: 0
Proxy-Settings: Type=0 IP= User=

2018/10/27 08:25:21.972 4714 139755021654848 S!! NetWatchDogLinux: Cannot enumerate inital network state, (DBus: 'org.freedesktop.DBus.Error.NoReply' (Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.) when calling 'org.freedesktop.DBus.Properties.Get' on '/org/freedesktop/NetworkManager'), Errorcode=11
2018/10/27 08:25:21.972 4714 139755021654848 S NetWatchDogLinux: using RTLink event handler
2018/10/27 08:25:21.972 4714 139755021654848 S NetWatchdog: LAN is now disconnected
2018/10/27 08:25:21.973 4714 139755021654848 S RemoteSettingsMDRelationshipWatchDog: DEVICE ISN'T A MANAGED DEVICE
2018/10/27 08:25:21.973 4714 139754167314176 S RemoteSettingsStore: Cleanup all policies.
2018/10/27 08:25:21.973 4714 139755021654848 S RemoteSettingsStoreListener: Establish connection.
2018/10/27 08:25:21.973 4714 139754167314176 S RemoteSettingsStore::LoadLastReceivedPolicies : Storage Entry Remote_Settings_TVClientSetting_Policy empty
2018/10/27 08:25:21.973 4714 139754167314176 S RemoteSettingsMDRelationshipWatchDog: DEVICE ISN'T A MANAGED DEVICE
2018/10/27 08:25:21.973 4714 139755021654848 S Using IPC-Port 5939
2018/10/27 08:25:21.973 4714 139754966267648 S OSSessionEventTranslatorLinux::RegisterSessionEven ts(): Start observing session events
2018/10/27 08:25:21.974 4714 139754966267648 S OSSessionEventTranslator::GenerateEventsForSession : SessionID = 4294967295, username = , primarySession = 0, unusable = 0, locked = 0, connected = 0
2018/10/27 08:25:21.974 4714 139754966267648 S OSSessionEventTranslator::GenerateEventsForSession : SessionID = 4294967295, username = , primarySession = 0, unusable = 0, locked = 0, connected = 0
2018/10/27 08:25:21.974 4714 139754966267648 S OSSessionEventTranslator::GenerateEventsForSession : SessionID = 3036032522, username = , primarySession = 1, unusable = 1, locked = 0, connected = 1
2018/10/27 08:25:21.974 4714 139754966267648 S OSSessionEventTranslator::GenerateEventsForSession : SessionID = 3510599056, username = root, primarySession = 0, unusable = 0, locked = 0, connected = 0
2018/10/27 08:25:21.974 4714 139754966267648 S UpdateOnlineState alwaysOnline=0 modifiedOnline=0 otherProcess=0 restart=0
2018/10/27 08:25:28.521 4714 139754175706880 S NetWatchdog: LAN is now connected
2018/10/27 08:25:28.521 4714 139754974660352 S CKeepAliveClientClient::HandleStartKeepAlive: doing nothing, online state = 2

sudo teamviewer daemon start
Лозинка:

/etc/init.d/teamviewerd start
teamviewerd | * WARNING: teamviewerd has already been started

sudo teamviewer daemon restart
Лозинка:

/etc/init.d/teamviewerd restart
teamviewerd | * Stopping teamviewerd ... [ ok ]
teamviewerd | * Starting teamviewerd ... [ ok ]

teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

and not start GUI

(1-19/19)

Thank you!