Update issue

Added by chris whittaker 26 days ago

Hi guys
After months of no issues I have hit a wall with this Update

I have a pretty much original instalation and it usually updates quite quick...today it took a couple of hours to calculate dependancies and then i got this below......first time it highlighted chromium as being masked ...which it wasnt, or not by me......anyway i tried uninstalling it

but on cl -update i get the readout below.....which i dont understand at all so if someone could be kind enough to direct me to the right way of fixing this i would be very grateful

*I do have and have had for a while a problem with browsers not working within the sandbox which i run

 qupzilla --no-sandbox

but it has never affected an update before

***
 * Update server http://www.gtlib.gatech.edu/pub/calculate
Updating packages
 * Calculating dependencies ...                                           [ ok ]
[binary     U  ] sys-apps/sed-4.5::gentoo [4.2.2::gentoo] USE="acl nls -forced-sandbox% (-selinux) -static" 273 KiB
[binary  NS    ] sys-devel/gcc-7.3.0-r3:7.3.0::gentoo [6.4.0-r1:6.4.0::gentoo] USE="cxx fortran nls nptl objc openmp pch pgo (pie) sanitize ssp vtv (-altivec) -cilk -debug -doc (-fixed-point) -go -graphite (-hardened) (-jit) (-libssp) -mpx (-multilib) -objc++ -objc-gc -regression-test -vanilla" 65220 KiB
[binary     U  ] app-arch/tar-1.30::gentoo [1.29-r3::gentoo] USE="acl nls xattr -minimal (-selinux) -static" 1032 KiB
[binary     U  ] dev-libs/libgpg-error-1.29::gentoo [1.27-r1::gentoo] USE="nls static-libs -common-lisp" 360 KiB
[binary     U  ] dev-libs/libgcrypt-1.8.3:0/20::gentoo [1.8.1:0/20::gentoo] USE="static-libs -doc -o-flag-munging%" 1146 KiB
[binary     U  ] media-libs/babl-0.1.50::gentoo [0.1.38::gentoo] USE="(-altivec)" CPU_FLAGS_X86="mmx sse sse2 sse3%* -f16c -sse4_1" 334 KiB
[binary  N     ] media-gfx/mypaint-brushes-1.3.0:1.0::gentoo  2340 KiB
[binary   R    ] x11-base/xorg-drivers-1.19::gentoo  INPUT_DEVICES="evdev keyboard libinput mouse synaptics -elographics -joystick -tslib -vmmouse -void -wacom" VIDEO_CARDS="amdgpu i915 i965 intel nouveau nv qxl radeon radeonsi vesa via virtualbox* -ast -dummy -fbdev (-freedreno) -geode -glint -mga (-newport) -nvidia (-omap) -r128 -siliconmotion (-tdfx) (-tegra) (-vc4) -vmware (-voodoo)" 17 KiB
[binary  N     ] x11-drivers/xf86-video-vboxvideo-1.0.0::gentoo  50 KiB
[binary     U  ] app-shells/bash-4.4_p12::gentoo [4.3_p48-r1::gentoo] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins" 1830 KiB
[binary     U  ] dev-libs/nss-3.37.3::gentoo [3.36.1::gentoo] USE="nss-pem utils -cacert" 2910 KiB
[binary     U  ] dev-util/gdbus-codegen-2.54.3::gentoo [2.52.3::gentoo] PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 160 KiB
[binary     U  ] dev-libs/glib-2.54.3-r6:2::gentoo [2.52.3:2::gentoo] USE="dbus mime xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" PYTHON_SINGLE_TARGET="python2_7%* -python3_5% -python3_6%" PYTHON_TARGETS="python2_7 python3_5%* -python3_6%" 5793 KiB
[binary  N     ] media-libs/gexiv2-0.10.8::gentoo  USE="introspection -python -static-libs {-test} -vala" PYTHON_TARGETS="python2_7 python3_5 -python3_4" 127 KiB
[binary  N     ] app-arch/gcab-0.8::gentoo  USE="introspection -vala" 109 KiB
[binary     U  ] x11-misc/xdg-utils-1.1.3-r1::gentoo [1.1.2-r1::gentoo] USE="-doc" 84 KiB
[binary     U  ] media-libs/libwebp-1.0.0:0/7::gentoo [0.5.2:0/6::gentoo] USE="gif jpeg opengl png tiff (-neon) -static-libs -swap-16bit-csp (-experimental%)" CPU_FLAGS_X86="avx2 sse2 sse4_1" 541 KiB
[binary  N     ] dev-libs/appstream-glib-0.6.13:0/8::gentoo  USE="introspection nls -stemmer" 466 KiB
[binary     U  ] app-crypt/gnupg-2.2.8::gentoo [2.2.4-r2::gentoo] USE="bzip2 nls readline smartcard ssl usb -doc -ldap (-selinux) -tofu -tools -wks-server" 3519 KiB
[binary     U  ] sys-apps/calculate-utils-3.5.8.15:3::calculate [3.5.8.14-r1:3::calculate] USE="backup client console dbus desktop install qt4 -minimal -pxe (-server)" PYTHON_TARGETS="python2_7" 2668 KiB
[binary     U  ] net-misc/openssh-7.7_p1-r5::gentoo [7.7_p1-r4::gentoo] USE="X pam pie ssl -X509 -audit -bindist -debug -hpn -kerberos -ldap -ldns -libedit -libressl -livecd -sctp (-selinux) -skey -static {-test}" 1673 KiB
[binary  NS    ] media-libs/gegl-0.4.2:0.4::gentoo [0.2.0-r5:0::gentoo] USE="cairo ffmpeg introspection jpeg2k openexr raw sdl svg tiff v4l webp -debug -lcms -lensfun {-test} -umfpack -vala" CPU_FLAGS_X86="mmx sse" 2220 KiB
[binary  NS    ] media-libs/gegl-0.3.26:0.3::gentoo [0.2.0-r5:0::gentoo] USE="cairo ffmpeg introspection jpeg2k openexr raw sdl svg tiff v4l webp -debug -lcms -lensfun {-test} -umfpack -vala" CPU_FLAGS_X86="mmx sse" 2029 KiB
[binary  N     ] www-client/chromium-66.0.3359.170::gentoo  USE="cups hangouts proprietary-codecs pulseaudio suid system-ffmpeg -component-build -custom-cflags -gnome-keyring -jumbo-build -kerberos (-neon) -pic (-selinux) (-system-icu) (-system-libvpx) (-tcmalloc) (-widevine)" L10N="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th tr uk vi zh-CN zh-TW" 0 KiB
[binary  N     ] media-libs/libmypaint-1.3.0::gentoo  USE="gegl introspection nls openmp" 173 KiB
[binary     U  ] net-print/hplip-3.18.5::gentoo [3.18.4::gentoo] USE="hpcups hpijs policykit qt5 scanner snmp -X -doc -fax -kde -libressl -libusb0 -minimal -parport -static-ppds" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 20119 KiB
[binary     U  ] media-gfx/gimp-2.10.2:2::gentoo [2.8.22-r1:2::gentoo] USE="alsa jpeg2k openexr%* python smp udev webp%* wmf -aalib (-altivec) (-aqua) -debug -doc -gnome -mng -postscript {-test} -vector-icons% -xpm (-bzip2%*) (-curl%) (-dbus%*) (-exif%*) (-jpeg%*) (-lcms%) (-pdf%*) (-png%*) (-svg%*) (-tiff%*)" CPU_FLAGS_X86="mmx sse" PYTHON_TARGETS="python2_7" 28726 KiB
[binary     U  ] net-print/hplip-plugin-3.18.5::gentoo [3.18.4::gentoo] 1446 KiB
[binary     U  ] media-sound/clementine-1.3.1_p20180523::gentoo [1.3.1_p20180416::gentoo] USE="box cdda dbus dropbox googledrive ipod mtp pulseaudio udisks -debug -lastfm -mms -moodbar -projectm -seafile -skydrive {-test} -wiimote" 5747 KiB
 * 29 packages will be installed, 151098 KiB will be downloaded
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libwebp:0

  (media-libs/libwebp-0.5.2:0/6::gentoo, installed) pulled in by
    >=media-libs/libwebp-0.3.0:0/6=[abi_x86_32(-)] required by (media-video/ffmpeg-3.3.6:0/55.57.57::gentoo, installed)
                              ^^^^^                                                                                                                        
    (and 7 more with the same problem)

  (media-libs/libwebp-1.0.0:0/7::gentoo, binary scheduled for merge) pulled in by
    >=media-libs/libwebp-0.6.0 required by (media-gfx/gimp-2.10.2:2/2::gentoo, binary scheduled for merge)
    ^^                   ^^^^^                                                                                                                                   
    >=media-libs/libwebp-0.5.0:0/7= required by (media-libs/gegl-0.4.2:0.4/0.4::gentoo, binary scheduled for merge)
                              ^^^^^                                                                                                                    
    (and 1 more with the same problems)


Replies (6)

RE: Update issue - Added by Mikhail Hiretsky 24 days ago

What distro do you use?

RE: Update issue - Added by chris whittaker 24 days ago

well its the latest Calculate Linux 17.12.2 xfce 32bit which ive been updating for 2 yrs approx

everything is working ok apart from this update and browsers running in a sandbox...

RE: Update issue - Added by Mikhail Hiretsky 21 days ago

Can you attach archive of /var/db/pkg ?

tar cjvf /tmp/vardbpkg.tar.bz2 --exclude=environment.bz2 /var/db/pkg

RE: Update issue - Added by chris whittaker 21 days ago

I Have attached the above needed archive in this Pastebin link i think ..i had capatch issues

http://pastebin.calculate-linux.org/en/show/521c271244bf14bcaf6b8b98fd945fee

Thank you for taking the time to look at this for me

I updated about 2 weeks ago with no problems and no problems since with daily useage ..My problem with Browsers not running in the sandbox has been around for a while

RE: Update issue - Added by Mikhail Hiretsky 20 days ago

Unfortunately, pastebin has only kept the list of files, but content of files is important also. Can you send this archive to my email ?

RE: Update issue - Added by chris whittaker 16 days ago

Have sent to your e-mail from and alternative source....Gmail wouldnt allow it ..

(1-6/6)

Thank you!