nvidia-drivers

Description:NVIDIA Accelerated Graphics Driver
Homepage:http://www.nvidia.com/ http://www.nvidia.com/Download/Find.aspx
Location:Portage
Legend:
  • + - stable
  • ~ - unstable
  • M - hardmask
alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86
384.59-r1 diff - ~ - - - - - - - - - - ~
384.47 diff - ~ - - - - - - - - - - ~
381.22-r1 diff - ~ - - - - - - - - - - ~
381.22 diff - + - - - - - - - - - - +
378.13-r1 diff - ~ - - - - - - - - - - ~
378.13 diff - + - - - - - - - - - - +
375.66-r1 diff - ~ - - - - - - - - - - ~
375.66 diff - + - - - - - - - - - - +
375.39 diff - + - - - - - - - - - - +
340.102-r1 diff - ~ - - - - - - - - - - ~
340.102 diff - + - - - - - - - - - - +
304.135-r1 diff - ~ - - - - - - - - - - ~
304.135 diff - + - - - - - - - - - - +
173.14.39-r2 diff - + - - - - - - - - - - +
173.14.39-r1 diff - + - - - - - - - - - - +
96.43.23-r1 - + - - - - - - - - - - +

USE flags

  • abi_mips_n32 - 64-bit (32-bit pointer) libraries
  • abi_mips_n64 - 64-bit libraries
  • abi_mips_o32 - 32-bit libraries
  • abi_ppc_32 - 32-bit (ppc) libraries
  • abi_ppc_64 - 64-bit (ppc64) libraries
  • abi_s390_32 - 32-bit (s390) libraries
  • abi_s390_64 - 64-bit (s390x) libraries
  • abi_x86_32 - 32-bit (x86) libraries
  • abi_x86_64 - 64-bit (amd64) libraries
  • abi_x86_x32 - x32 ABI libraries
  • acpi - Add support for Advanced Configuration and Power Interface
  • compat - Install non-GLVND libGL for backwards compatibility
  • custom-cflags - Build with user-specified CFLAGS (unsupported)
  • driver - Install the kernel driver module
  • gtk - Add support for x11-libs/gtk+ (The GIMP Toolkit)
  • gtk3 - Install nvidia-settings with support for GTK+ 3
  • kernel_FreeBSD - KERNEL setting for system using the FreeBSD kernel
  • kernel_linux - KERNEL setting for system using the Linux kernel
  • kms - Enable support for kernel mode setting (KMS)
  • multilib - On 64bit systems, if you want to be able to compile 32bit and 64bit binaries
  • pax_kernel - PaX patches from the PaX project
  • static-libs - Build static versions of dynamic libraries as well
  • tools - Install additional tools such as nvidia-settings
  • userland_BSD - USERLAND setting for systems using BSDish userland (FreeBSD OpenBSD NetBSD DragonFly)
  • uvm - Install the Unified Memory kernel module (nvidia-uvm) for sharing memory between CPU and GPU in CUDA programs
  • wayland - Enable dev-libs/wayland backend
  • X - Install the X.org driver, OpenGL libraries, XvMC libraries, and VDPAU libraries

Security Advisory

Date Severity Title
over 3 years high NVIDIA Drivers: Privilege Escalation
over 4 years high NVIDIA Drivers: Privilege escalation
about 5 years high NVIDIA Drivers: Privilege escalation
almost 10 years normal NVIDIA drivers: Denial of Service
over 10 years high NVIDIA binary graphics driver: Privilege escalation vulnerability

Also available in: Atom

Thank you!