GLSA 201711-08: LibXfont, LibXfont2: Multiple vulnerabilities

Severity:normal
Title:LibXfont, LibXfont2: Multiple vulnerabilities
Date:11/11/2017
Bugs: #634044
ID:201711-08

Synopsis

Multiple vulnerabilities have been found in LibXfont and Libxfont2, the worst of which could allow attackers to cause a Denial of Service condition.

Background

X.Org Xfont library

Affected packages

Package Vulnerable Unaffected Architecture(s)
x11-libs/libXfont < 1.5.3 >= 1.5.3 All supported architectures
x11-libs/libXfont2 < 2.0.2 >= 2.0.2 All supported architectures

Description

Multiple vulnerabilities have been discovered in LibXfont and LibXfont2. Please review the referenced CVE identifiers for details.

Impact

Local attackers could obtain sensitive information or possibly cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All LibXfont2 users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose ">=x11-libs/libXfont2-2.0.2"
    

All LibXfont users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=x11-libs/libXfont-1.5.3"

References

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-201711-08.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

License

Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!