GLSA 201709-22: Oracle JDK/JRE, IcedTea: Multiple vulnerabilities

Severity:normal
Title:Oracle JDK/JRE, IcedTea: Multiple vulnerabilities
Date:09/24/2017
Bugs: #625602, #626088, #627682
ID:201709-22

Synopsis

Multiple vulnerabilities have been found in Oracle's JRE and JDK software suites, and IcedTea, the worst of which may allow execution of arbitrary code.

Background

Java Platform, Standard Edition (Java SE) lets you develop and deploy Java applications on desktops and servers, as well as in today’s demanding embedded environments. Java offers the rich user interface, performance, versatility, portability, and security that today’s applications require.

IcedTea’s aim is to provide OpenJDK in a form suitable for easy configuration, compilation and distribution with the primary goal of allowing inclusion in GNU/Linux distributions.

Affected packages

Package Vulnerable Unaffected Architecture(s)
dev-java/icedtea-bin < 7.2.6.11 >= 7.2.6.11 All supported architectures
dev-java/oracle-jre-bin < 1.8.0.141 >= 1.8.0.141 All supported architectures
dev-java/oracle-jdk-bin < 1.8.0.141 >= 1.8.0.141 All supported architectures

Description

Multiple vulnerabilities have been discovered in Oracle’s JRE, JDK and IcedTea. Please review the referenced CVE identifiers for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or gain access to information.

Workaround

There is no known workaround at this time.

Resolution

All Oracle JDK binary users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-java/oracle-jdk-bin-1.8.0.141"
    

All Oracle JRE binary users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=dev-java/oracle-jre-bin-1.8.0.141"

All IcedTea binary 7.x users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=dev-java/icedtea-bin-7.2.6.11"

All IcedTea binary 3.x users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=dev-java/icedtea-bin-3.5.0"

References

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-201709-22.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

License

Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!